Система не видит типов материалов

Втр, 13/09/2011 - 09:40

Друпал7, последняя.
Создано несколько типов материалов, ну и еще 2 стандартные. На странице отображения типов они есть.

Но вот когда жму на кнопку "Добавить содержимое" - надпись, что типов нет и предложение их создать. Также с автосинонимами. Ни к одному старому типу автосинонимы не подключаются.

Зато если я создаю новый тип материала: тут и в добавить содержимое его видно, и автосинонимы с ним согласны работать. Что за?

0 Спасибо

Комментарии

Аватар пользователя vicshine
5 лет 4 months назад vicshine #

1. Такая проблема у админа или для любого зарег. пользователя?
2. Что пишет сайт, если перейти по yoursite.ru/node/add ?

0 Спасибо
Аватар пользователя digital_sword
5 лет 4 months назад digital_sword #

1. У любого пользователя.
2. Как и писал, "Вы не создали ни одного материала. Откройте страницу создания материалов чтобы создать новые материалы."

Удаление и создание типа материала с тем же машинным именем не помогает. Сайт помнит, какие типы материалов уже были.

Вообще тип можно создать, если написать напрямую node/add/article, или другое. Все бы ничего, но автосинонимы со старыми типами не работают. Думаю причина одна и та же.

0 Спасибо
Аватар пользователя vicshine
5 лет 4 months назад vicshine #

Проверьте права на добавление материала. Возможно сбились.

0 Спасибо
Аватар пользователя digital_sword
5 лет 4 months назад digital_sword #

Не, у пользователя №1 все права. И создать то я все равно могу. Да и автосинонимы для них тогда почему не работают?
Галки поставил все.

0 Спасибо
Аватар пользователя vicshine
5 лет 4 months назад vicshine #
digital_sword написал:
Галки поставил все.

Честно, напоминает мою давнюю тему. В смысле, непонятное-неочевидное :(

Пробуйте чистить кэш. Если есть бэкапы - откатиться.
Больше даже не знаю чего рекомендовать ;)

0 Спасибо
Аватар пользователя digital_sword
5 лет 4 months назад digital_sword #

не как в вашем случае. Смена темы не помогает. Кэш сто раз чистил. И модули все отключал

0 Спасибо
Аватар пользователя Frantsuzzz
4 года 11 months назад Frantsuzzz #

http://www.drupal.ru/node/64376
Посмотрите тут.

У меня другая проблема появилась. После установки drupal7 все работало. Типы материалов создавались, в списке node/add отображались и по ссылке node/add/mymaterial создавались.
Сегодня попробовал создать новый тип материала: он в базу записывается а вот ссылки на создание не работают.
Такое ощущение, что не записываются пути.
И кстати views также создает страницы, но когда переходишь по ссылке, пишет что страница не найдена.
В журнале друпала нашел ошибку:

PDOException: в функции _menu_router_save() (строка 3768 в файле /home/user2099/zoo.vrassove.com/includes/menu.inc).
источником ошибки вылазят разные модули (/admin/structure/menu, /admin/node/add )

Кто сталкивался с такой ошибкой? В какую сторону копать.

0 Спасибо
Аватар пользователя Frantsuzzz
4 года 11 months назад Frantsuzzz #

Короче, так и не разобрался в этой проблеме. Обновление друпала не устранило проблему. Скорее всего она кроется в установленных(удаленных) модулях (может какой модуль некорректно удалился). Пришлось откатить сайт на несколько дней назад. Это помогло.

0 Спасибо
Аватар пользователя disruptive
4 года 9 months назад disruptive #

Решение:
Переходим admin/structure/menu/manage/navigation и включите пункты Статья, Страница и ваши типы материалов

0 Спасибо
Аватар пользователя livestd
4 года 1 month назад livestd #

admin/structure/menu/manage/navigation бла бла бла не помогает(
может есть другие способы решения? откат для меня - не вариант

0 Спасибо
Аватар пользователя livestd
4 года 1 month назад livestd #

Решено! вся проблема ошибки PDOException: в функции _menu_router_save() (строка 3813 в файле /home/cp783848/public_html/idemdomoi/includes/menu.inc). В неизвестных символах. При архивации-разархивации глючат латинские символы. Все папки, в названиях которых есть подобные символы нужно удалить. Так-же желательно проверить меню, возможно там зачешется подобная "Ё".
На удивление после удаления из папки themes всех неправильных папок, сразу все работать не стало. Очистка кэша тож не помогла. И пришел шаман с бубном. Вобщем залил пустую тему с тем-же названием, потом вернул все на место и все заработало.

0 Спасибо
Аватар пользователя Shvapsss
4 months 3 недели назад Shvapsss #

Спасибо, помогло:

Решение:
Переходим admin/structure/menu/manage/navigation и включите пункты Статья, Страница и ваши типы материалов

0 Спасибо
Аватар пользователя mbaev
4 months 3 недели назад mbaev #
Shvapsss написал:
Спасибо, помогло:

Ткните "Решение" в меню комментария, который вам помог.

0 Спасибо
Аватар пользователя Studio VIZA
4 months 3 недели назад Studio VIZA #
mbaev написал:
Ткните "Решение"

Только ТС может это сделать же.

0 Спасибо
Аватар пользователя mbaev
4 months 3 недели назад mbaev #

Это смотря как сильно хотеть!

0 Спасибо