Drupal 8

Втр, 20/10/2015 - 06:16

Попытка познакомиться с Drupal 8 закончилась неудачей(((
Значит при первом запуске на openserver у меня стоит php 5.3 и apache 2.2 получаю ошибку:
Parse error: syntax error, unexpected '[', expecting ')' in E:\OpenServer\domains\drupal8\vendor\guzzlehttp\promises\src\functions.php on line 41
Начинаю гуглить ничего не нахожу. После смотрю системные требования php 5.6 и apache 2.4. Меняю версии в openserver и получаю ошибку отсутствия файла msvcr100.dll. Начинаю копать дальше, ставлю какие-то библиотеки C++ с оф сайта майкрософт, и теперь получаю ошибку "Ошибка при запуске приложения (0x000007b). Для выхода из приложения нажмите кнопку ОК".
Что делать?

0 Спасибо

Комментарии

Аватар пользователя ttenz
1 год 7 months назад ttenz #

ещё можно на окна aquia dev desktop 2, там уже встроенная восьмерка.

0 Спасибо
Аватар пользователя mozh
1 год 7 months назад mozh #
sas@drupal.org написал:
На окна поставьте http://open-server.ru/ он справится

именно на Openserver и пробую

0 Спасибо
Аватар пользователя dashiwa
1 год 7 months назад dashiwa #

Денвер - колорадо

0 Спасибо
Аватар пользователя Tesmon
1 год 5 months назад Tesmon #

Я на хостинге джино.ру получил только что это:
Parse error: syntax error, unexpected '[', expecting ')' in /home/users/t/tesmon/domains/XXX.XXX.ru/vendor/guzzlehttp/promises/src/functions.php on line 41
Тоже знакомство не удалось...

Чуть позже:
О! Да тут всё быстро решается самостоятельно)
Большая картинка: http://www.drupal.ru/files/field/comment_node_blog/2015-12-12_00-55-00_skrinshot_ekrana_0.png

0 Спасибо
Аватар пользователя mozh
1 год 5 months назад mozh #

не могу увеличить скрин ваш

0 Спасибо
Аватар пользователя Tesmon
1 год 5 months назад Tesmon #

Добавил прямую ссылку на большую картинку

0 Спасибо
Аватар пользователя mozh
1 год 5 months назад mozh #

спс, версию на openserver менял не помогало, позже попробую...

0 Спасибо
Аватар пользователя Lotar
1 год 5 months назад Lotar #

Рано с ним знакомится. Сыроват и с модулями напряг.

0 Спасибо
Аватар пользователя Tesmon
1 год 5 months назад Tesmon #

Ну релиз же...
А модули... мне может и коробочного функционала хватит, супер-пупер порталы не делаю.
Самое важное в моём случае, это не иметь в дальнейшем проблем с обновлением системы )

0 Спасибо
Аватар пользователя tlito
1 год 5 months назад tlito #

надо большими буквами писать

для работы друпал 8 нужен php 5.6 или выше.


но если ниже, то вы будете иметь ошибки

0 Спасибо
Аватар пользователя leo7
3 months 4 недели назад leo7 #

т.е. на апаче 2.2 не вытащит? нужен мин. 2.4, кто-то знает?

0 Спасибо
Аватар пользователя leo7
3 months 4 недели назад leo7 #

в Open Server не смог подобрать вариант ниже, чем апач 2.4, вот и пытаюсь уточнить
Что на Орге ставят точки после 2..., видел. Так и не понял: можно на 2.2, или будут траблы..?

0 Спасибо
Аватар пользователя multpix
3 months 4 недели назад multpix #

Если у вас проблемы с пониманием как это работает (и вы на винде),
то начните с оригинальной коробки: https://docs.acquia.com/dev-desktop
(есть все что нужно)
а продакшн отдайте сисадмину.

Я же - использую встроенный пыховый сервер (для dev) или nginx.

0 Спасибо
Аватар пользователя leo7
3 months 4 недели назад leo7 #

я на винде, понимания нет,но я и есть админ, я и веду продакшн.
(попытки, многократные, найти админа за 7 лет ни к чему не привели).

Решаю сейчас задачу инсталляции сервера, для перехода сайтов, вот и пытаюсь понять: что за затык с апачем.
В опен сервер есть апач 2.2, и апач 2.4.И есть сочетания, которые в нём, т.е в ОС, не поднимаются.
Например, 64бит вообще не запускаются, хотя пробую на Open Server x64

Пока вижу, что только апач 2.4 ОС согласен сочетать с нужными версиями пхп и мускула..
если б прошло на 2.2., было б меньше проблем.

0 Спасибо
Аватар пользователя leo7
3 months 3 недели назад leo7 #

PHP Version 5.6.30 удалось натянуть на 7, апач 2.4, MySQL(i) 5.5.52-MariaDB
были проблемы с доступом к файлам,
Хостеры сказали:
«перевели веб -сервер на режим itk, что должно решить указать указанные вами ошибки.
Так же вернули права на директории 775 и 664 на файлы. При этом ошибок доступа не наблюдаем»

я так понял, это что-то мне ослабит в надёжности?
теперь буду пробовать шагнуть в 8

0 Спасибо